Suoraan sisältöön

Ubuntun yhteensopivuus vanhojen tietokoneiden kanssa

Ubuntu on loistava valinta kaikille tietokoneille. Se toimii mainiosti jopa reilusti yli 10 vuotta vanhoilla tietokoneilla kaikkine tietoturvapäivityksineen, kunhan asennettava Ubuntu-versio valitaan oikein. Asentamiseen voit seurata lataussivun ja asennusoppaan ohjeita!

Mikä Ubuntu valita?

Ubuntu toiminnassa

Alla on pikaopas suositetuimpaan Ubuntu-versioon, ottaen huomioon tietokoneen iän ja ominaisuudet:

Ubuntu

Tuorein Ubuntu sopii lähes kaikille vuoden 2007 jälkeen valmistetuille tietokoneille.

Osa ensimmäisen sukupolven miniläppäreistä ei tukenut 64-bittistä suoritustilaa. Näille, sekä muille vanhemmille tietokoneille (rajana suurin piirtein vuosi 2007) voi käyttää 32-bittistä Ubuntua. Jos epäilet tietokoneen graafisten tehojen (näytönohjain) riittävyyttä, harkitse alempana olevaa Ubuntun kevytversiota.

Valmistusvuosi ja vaaditut ominaisuudet

Ladattava Ubuntu-versio

2007 tai myöhemmin, 2GB tai enemmän RAM-keskusmuistia, OpenGL 2.0

Ubuntu 16.04 LTS (64-bit)

ennen 2007, 1GB tai enemmän RAM-keskusmuistia, OpenGL 2.0

Ubuntu 16.04 LTS (32-bit)

Kevyt ”Lubuntu”

Lubuntu on Ubuntu varustettuna hyvin kevyellä LXDE-työpöydällä. Se ei vaadi tietokoneelta mitään erityistä, mutta tietokoneen keskusmuistin perusteella kannattaa valita oikea asennusmedia.

Tietokoneen ominaisuudet

Ladattava Ubuntu-versio

768MB tai enemmän RAM-keskusmuistia

Lubuntu 16.04 LTS (32-bit)

256MB-512MB RAM-keskusmuistia

Lubuntu 16.04 LTS (32-bit, tekstipohjainen asennusohjelma)

192MB-256MB RAM-keskusmuistia

Lubuntu 14.04 LTS (32-bit, tekstipohjainen asennusohjelma)

Kirjastoissa olevat Ubuntu 16.04 LTS- ja 14.04 LTS -levyt ovat 64-bittisiä (12.04 LTS -levyt 32-bittisiä, mutta tuki vain vuoteen 2017).

Lataussivulta on linkit ohjeisiin siitä, kuinka ladattu tiedosto laitetaan esimerkiksi USB-tikulle, jolta Ubuntu tietokoneeseen asennetaan.


Lisätietoja

PAE-ominaisuutta tai OpenGL 2.0:aa ilman olevat tietokoneet

Jotkin vanhemmista tietokoneista eivät tue ”PAE” (Physical Address Extension) -ominaisuutta, jota Ubuntun Linux-ydin käyttää. Tämä on merkittävää siltä osin, että jo vuonna 1995 tuotiin tätä tukevat suorittimet markkinoille. On kuitenkin olemassa tietty määrä vuosina 2003-2005 valmistettuja Intel Celeron M- ja Pentium M -suorittimia, joissa PAE-tuki on piilotettu näkyvistä niin että käyttöjärjestelmä luulee että sitä ei ole.

Lisäksi osa vanhemmista tietokoneista ei tue OpenGL 2.0 -grafiikkastandardia, jolloin uusinta Ubuntu 16.04 LTS -julkaisua ei voi enää käyttää Unity 7 -työpöydällä.

Näille sekä muille vanhoille koneille on suositeltavinta asentaa Lubuntu 16.04 LTS, joka toimii PAE-ongelmallisten Celeron M- ja Pentium M-suorittimienkin kanssa ja tarjoaa hyvin kevyen LXDE-työpöydän. PAE-ongelmallisilla koneilla tämä vaatii lisäksi forcepae-parametrin käyttöä tietokonetta tikulta ensimmäistä kertaa käynnistettäessä. Lubuntu tulee myös hyvin toimeen yli 10 vuotta vanhoissa koneissa usein vähissä olevan RAM-käyttömuistin kanssa. Katso sivun yläreunan taulukosta sopivin Lubuntu-versio RAM-muistin määrän mukaan

Vanhempi Ubuntu-versio vaihtoehtona?

Joissain harvinaisemmissa tapauksissa Ubuntussa olevan Linux-ytimen laitetuki jollekin vanhalle konetyypille on voinut rapistua ajan myötä, jolloin vanhempi Ubuntu-versio 12.04 LTS voi tarjota korjauksen ihmettelyä helpomman vaihtoehdon. Esimerkiksi joillain Pentium 4 -koneilla 12.04 LTS on toiminut paremmin.

Myös jos ylempänä puhuttu PAE-tuki puuttuu kokonaan (1990-luvun tietokoneet), saattaa vanhempi Ubuntu olla tarpeen.

Vuonna 2012 alun perin julkaistu Ubuntu 12.04 LTS on tuettu tietoturvapäivitysten osalta vuoden 2017 huhtikuuhun asti. Seuraavia vois siis harkita kokeiltavaksi: